I am posting GNS3 Topology and lab config for Basic MPLS lab presented in Knowledge Net Student Guide 2.0. I am sure this will provide useful help to the poeples who are in the journery of learning MPLS and save lot of time in configuring basic IP configuration and to setup basic lab. This is full configured and fuctional lab by using IOS "c3640-jk9o3s-mz.124-16.bin"
Click the below "Show Config" link to see sample config of PE11 Router and get complete configuration with GNS3 topology file from " knowledgnet mpls lab.zip
Show Config /Hide Config
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE11
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
ip vrf cust-a
rd 1:10
route-target export 1:10
route-target import 1:10
!
ip vrf cust-b
rd 1:15
route-target export 1:15
route-target import 1:15
!
!
!
interface Loopback0
ip address 192.168.1.17 255.255.255.255
!
interface Serial0/0
ip address 192.168.1.49 255.255.255.240
mpls label protocol ldp
mpls ip
serial restart-delay 0
!
interface Serial0/1
ip vrf forwarding cust-a
ip address 150.1.1.18 255.255.255.240
serial restart-delay 0
!
interface Serial0/2
ip vrf forwarding cust-b
ip address 150.1.1.34 255.255.255.240
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
router eigrp 10
network 150.1.0.0
network 192.168.1.0
no auto-summary
!
router rip
version 2
!
address-family ipv4 vrf cust-b
redistribute bgp 65001 metric transparent
network 150.1.0.0
no auto-summary
exit-address-family
!
address-family ipv4 vrf cust-a
redistribute bgp 65001 metric transparent
network 150.1.0.0
no auto-summary
exit-address-family
!
router bgp 65001
no synchronization
bgp log-neighbor-changes
neighbor 192.168.1.33 remote-as 65001
neighbor 192.168.1.33 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 192.168.1.33 activate
neighbor 192.168.1.33 send-community both
neighbor 192.168.1.33 next-hop-self
exit-address-family
!
address-family ipv4 vrf cust-b
redistribute static
no synchronization
exit-address-family
!
address-family ipv4 vrf cust-a
redistribute rip
no synchronization
exit-address-family
!
ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
!
end
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE11
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
ip vrf cust-a
rd 1:10
route-target export 1:10
route-target import 1:10
!
ip vrf cust-b
rd 1:15
route-target export 1:15
route-target import 1:15
!
!
!
interface Loopback0
ip address 192.168.1.17 255.255.255.255
!
interface Serial0/0
ip address 192.168.1.49 255.255.255.240
mpls label protocol ldp
mpls ip
serial restart-delay 0
!
interface Serial0/1
ip vrf forwarding cust-a
ip address 150.1.1.18 255.255.255.240
serial restart-delay 0
!
interface Serial0/2
ip vrf forwarding cust-b
ip address 150.1.1.34 255.255.255.240
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
router eigrp 10
network 150.1.0.0
network 192.168.1.0
no auto-summary
!
router rip
version 2
!
address-family ipv4 vrf cust-b
redistribute bgp 65001 metric transparent
network 150.1.0.0
no auto-summary
exit-address-family
!
address-family ipv4 vrf cust-a
redistribute bgp 65001 metric transparent
network 150.1.0.0
no auto-summary
exit-address-family
!
router bgp 65001
no synchronization
bgp log-neighbor-changes
neighbor 192.168.1.33 remote-as 65001
neighbor 192.168.1.33 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 192.168.1.33 activate
neighbor 192.168.1.33 send-community both
neighbor 192.168.1.33 next-hop-self
exit-address-family
!
address-family ipv4 vrf cust-b
redistribute static
no synchronization
exit-address-family
!
address-family ipv4 vrf cust-a
redistribute rip
no synchronization
exit-address-family
!
ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
!
end
No comments:
Post a Comment